存档在 2018年1月

怎样编译安装PHP5.6.*

2018年1月27日

参考:http://amon.org/php72

通过源码包编译安装:

下载:http://php.net/downloads.php
最新版本:php-5.6.38

wget http://php.net/distributions/php-5.6.38.tar.xz && tar -xvf php-5.6.38.tar.xz && cd php-5.6.38

开始configure配置:

./configure --prefix=/usr/local/php --with-config-file-path=/usr/local/php/etc --enable-fpm --with-fpm-user=apache --with-fpm-group=apache --disable-debug --with-curl --with-iconv --with-pcre-regex --with-zlib --enable-bcmath --enable-ftp --enable-sockets --enable-mbstring --enable-mbregex --enable-soap --with-xsl --with-openssl --enable-opcache=no --with-mysql --with-mysqli --with-mysql-sock --with-pdo-mysql --enable-mysqlnd --disable-fileinfo --with-gd=/usr/local/gd --enable-gd-jis-conv --with-jpeg-dir=/usr/local/jpeg/lib --with-png-dir=/usr/local/png --with-freetype-dir=/usr/local/freetype --with-libzip=/usr/local/libzip --enable-zip --with-iconv-dir=/usr/local/lib --with-readline --with-apxs2=/usr/local/apache2/bin/apxs LDFLAGS="-L/usr/lib -lz"

如果configure时报错:Cannot find ldap libraries

configure: error: Cannot find ldap libraries in /usr/lib

参考:http://www.111cn.net/sys/linux/44746.htm

提示在/usr/lib 下找不到相关模块,这是因为64位的linux默认把以上文件都存在 /usr/lib64 文件夹下。

cp -frp /usr/lib64/libldap* /usr/lib/

如果configure时报错:off_t undefined

checking size of off_t… 0
configure: error: off_t undefined; check your library configuration

参考:https://stackoverflow.com/questions/44941513/php-compile-off-t-undefined
参考:https://stackoverflow.com/questions/44941513/php-compile-off-t-undefined
参考:http://ju.outofmemory.cn/entry/319609

echo '/usr/local/lib64 /usr/local/lib /usr/lib /usr/lib64'>>/etc/ld.so.conf && ldconfig
ln -s -f /usr/include/zipconf.h /usr/local/include/zipconf.h

然后开始 make:

make ZEND_EXTRA_LIBS='-liconv'

如果make时报错:undefined reference to symbol ‘ber_scanf’

/usr/bin/ld: ext/ldap/.libs/ldap.o: undefined reference to symbol 'ber_scanf'
/usr/bin/ld: note: 'ber_scanf' is defined in DSO /lib64/liblber-2.4.so.2 so try adding it to the linker command line
/lib64/liblber-2.4.so.2: could not read symbols: Invalid operation
collect2: error: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1

参考:http://www.oschina.net/question/56833_128548?sort=time

编辑MakeFile,找到 110行 开头是 ‘EXTRA_LIBS’ 这一行 在结尾加上 ‘-llber’ :

EXTRA_LIBS = -lcrypt -lcrypto -lssl -lcrypto -lzip -lz -lexslt -lcrypt -lreadline -lncurses -lrt -lmcrypt -lltdl -lldap -lstdc++ -lgmp -lgd -lpng -lz -ljpeg -lpng -lz -ljpeg -lcurl -lbz2 -lz -lcrypto -lssl -lcrypto -lrt -lm -ldl -lnsl -lxml2 -lz -lm -ldl -lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err -lcurl -lxml2 -lz -lm -ldl -lfreetype -lfreetype -ldl -lm -licui18n -licuuc -licudata -ldl -lm -licuio -lxml2 -lz -lm -ldl -lxml2 -lz -lm -ldl -lcrypt -lxml2 -lz -lm -ldl -lxml2 -lz -lm -ldl -lxml2 -lz -lm -ldl -lxml2 -lz -lm -ldl -lxslt -lxml2 -lz -ldl -lm -lcrypt -llber

重新make(注意不能make clean,因为这样的话MakeFile会还原):

make ZEND_EXTRA_LIBS='-liconv'

输出:

...
Build complete.
Don't forget to run 'make test'

执行命令:

make test

有时候进程会卡死,止步于:

...
PASS Bug #66830 (Empty header causes PHP built-in web server to hang) [sapi/cli/tests/bug66830.phpt]

那就绕开此步,关闭进程后,重启进程直接“make install”。

执行命令:

make install

输出:

...
libtool: install: install .libs/libphp7.so /usr/local/apache2/modules/libphp7.so
...
Installing PEAR environment:      /usr/local/php/lib/php/
...
Wrote PEAR system config file at: /usr/local/php/etc/pear.conf
You may want to add: /usr/local/php/lib/php to your php.ini include_path
/root/php/php-5.6.38/build/shtool install -c ext/phar/phar.phar /usr/local/php/bin
ln -s -f phar.phar /usr/local/php/bin/phar
Installing PDO headers:           /usr/local/php/include/php/ext/pdo/

运行:

libtool --finish /root/php/php-5.6.38/libs

添加/usr/local/php/lib/php to your php.ini include_path:

/root/php/php-5.6.38/build/shtool install -c ext/phar/phar.phar /usr/local/php/bin
ln -s -f phar.phar /usr/local/php/bin/phar

创建软连接:

ln -s /usr/local/php/bin/php /usr/local/bin/
ln -s /usr/local/php/bin/phpize /usr/local/bin/
ln -s /usr/local/php/bin/php-config /usr/local/bin/

查看版本:

php -v

输出:

PHP 5.6.38 (cli) (built: Oct 28 2016 03:13:49)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2015 Zend Technologies

重启Apache:

service httpd stop && service httpd start

报错:

/etc/init.d/httpd: line 81:  3668 Segmentation fault      $HTTPD -k $ARGV

原因在于Apache配置文件中模块libphp5.so还在加载中,但是5已经被删除了,新安装了7,所以需要将libphp5.so这一行注释掉,只加载libphp7.so。

打开httpd.conf文件:

/usr/local/apache2/conf/httpd.conf

将libphp5.so这一行注释掉:

#LoadModule php5_module modules/libphp5.so
LoadModule php7_module modules/libphp7.so

重启Apache:

service httpd start

Apache正常启动。

常见报错备注

备注1:

通过源码编译安装zlib跟libzip后,必须在configure中指定以下两个参数的路径:

--with-zlib-dir=DIR
--with-libzip=DIR

否则会出现报错。

备注2:–with-mysql

中间只报告了一个mysql无法扩展无法安装。

因为PHP7已经移除mysql了,现在主要使用mysqli和pdo连接mysql。

在configure 命令中 删除 –with-mysql 这一项即可。

备注2:–enable-opcache=no

使用大于php5.4版本的时候–enable-opcache可能会在./configure阶段就报错:

configure: error: Don't know how to define struct flock on this system, set --enable-opcache=no

这句话的意思是让你关闭opcache,但是既然要使用新版本为何不开启opcache?执行下面这2句:

echo "/usr/local/lib">> /etc/ld.so.conf
ldconfig -v

以上操作是更新动态库,只有这样设置之后才能安装opcache选项。

常见报错:#error unsupported size of off_t

在make的时候又出现了编译错误:

In file included from /home/data/php-5.6.38/ext/zip/lib/zip_add.c:36:0:
/home/data/php-5.6.38/ext/zip/lib/zipint.h:126:2: error: #error unsupported size of off_t
 #error unsupported size of off_t
  ^
make: *** [ext/zip/lib/zip_add.lo] Error 1

https://bugs.php.net/bug.php?id=68302找到了答案:

执行命令:

export CFLAGS="-L/opt/xml2/lib"

然后清除上一次编译的错误:

make clean

重新执行configure命令编译。

怎样部署Wiki

2018年1月25日

比较:https://www.wikimatrix.org/compare/DokuWiki+MediaWiki

【DokuWiki】

https://www.dokuwiki.org/dokuwiki#
https://www.jianshu.com/p/a6b00b055fcd
http://www.pythonclub.org/dokuwiki/start
https://download.dokuwiki.org/

https://www.dokuwiki.org/rewrite
http://www.cnblogs.com/zhaorui/archive/2009/12/10/20091210_dokuwiki_urlrewrite.html

http://lotar.altervista.org/wiki/wiki/syntax

http://www.dokuwiki.com.cn/category/install/theme
https://www.dokuwiki.org/template:bootstrap3

http://www.usefulshare.com/nilejiang/solve-dokuwiki-security-problem.html

【MediaWiki】

https://www.mediawiki.org/wiki/MediaWiki

https://jamesqi.com/MediaWiki
https://www.jamesqi.com/MediaWiki%E5%85%8B%E9%9A%86%E7%B9%81%E4%BD%93%E7%BD%91%E7%AB%99

http://www.51php.com/mediawiki
https://www.zhihu.com/question/20753047/answer/130872811
https://www.zhihu.com/question/20519061

使mediawiki侧边导航呈现折叠效果


https://www.zhihu.com/question/20753047/answer/130872811

https://starbounder.org/Starbound_Wiki
https://factorio.huijiwiki.com/wiki/%E9%A6%96%E9%A1%B5

怎样注册.PRO域名

2018年1月19日

【介绍】

【查询】

https://www.namecheap.com/domains/registration/results.aspx

【注册】

https://www.domcomp.com/tld/pro

$1.88
http://www.namecheap.com/

$2.99
http://www.dynadot.com/

$6.99
http://www.godaddy.com/

【删除】

https://member.expireddomains.net/domains/expiredpro/

【应用】

huobi.pro

【拾贝】

benbi.pro
beibi.pro
xuebi.pro

怎样注册.KE域名

2018年1月10日

【介绍】

ke : Kenya, 肯尼亚

域名注册局:KeNIC http://www.kenic.or.ke/

https://news.gandi.net/zh-hans/2017/12/ke-yu-ming-de-you-xian-zhu-ce-jie-duan-zhi-dao-12-yue-22-ri/

从 2017 年 12 月 23 日开始, .ke 即会开放给所有域名申请者。

【注册】

$59.33 5999KES/1year
https://kenyawebexperts.com/cart.php?a=add&domain=register

$64.29 6500KES/1year
https://afriregister.co.ke/checkavailableforregister.php

$83
http://www.lexsynergy.com/domain-availability-checker

€86
https://www.netim.com/domain-name/search-registration.html

$99.99
https://www.101domain.com/domain-availability-search.htm

¥1050
https://www.gandi.net/zh-hans/tlds/ke/prices
此域名必须要成为 Gandi 企业客户 后才能注册。 如果您需要更多的资讯,请与 我们的企业客户服务 联络。

【关注】

wei.ke
注册商:101domain.com
注册日期:2018-01-19
状态:pendingCreate

you.ke
注册商:101domain.com
注册日期:2018-01-19
状态:pendingCreate

lian.ke
注册商:101domain.com
注册日期:2018-01-19
状态:OK

wang.ke
注册商:101domain.com
注册日期:2018-01-20
状态:OK

怎样注册.GG域名

2018年1月7日

【介绍】

https://zhuanlan.zhihu.com/p/25214137

【价格】

¥298
http://www.west263.hk/main/whois.asp

价格比较:
https://www.domcomp.com/tld/gg