报错:Requires: libnghttp2.so.14()(64bit)

2020年3月19日 | 分类: 【技术】

背景:需要升级 CentOS 7

报错:

...
Error: Package: libcurl-7.69.1-1.1.cf.rhel7.x86_64 (city-fan.org)
           Requires: libnghttp2.so.14()(64bit)
           Removing: libnghttp2-1.31.1-1.el7.x86_64 (@/libnghttp2-1.31.1-1.el7.x86_64)
               libnghttp2.so.14()(64bit)
           Updated By: libnghttp2-1.31.1-2.el7.i686 (city-fan.org)
               Not found
...

参考:https://centos.pkgs.org/7/epel-x86_64/libnghttp2-1.31.1-2.el7.x86_64.rpm.html

yum install https://download-ib01.fedoraproject.org/pub/epel/7/x86_64/Packages/l/libnghttp2-1.31.1-2.el7.x86_64.rpm

然后执行升级,不再报错。