问题:The following packages have been kept back

2022年9月28日 | 分类: 【技术】

新开了一个 Ubuntu 22.04 系统,升级系统时出现:

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  libnss-systemd libpam-systemd libsystemd0 libudev1 systemd systemd-sysv
  systemd-timesyncd udev
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.

参考:https://itsfoss.com/following-packages-have-been-kept-back/

The fix for this error is really simple. All you have to do is to use the apt install command with package or packages in the question

参考:https://www.codenong.com/f-following-packages-have-been-kept-back/

解决此错误的方法非常简单。您所要做的就是对问题中的一个或多个软件包使用apt install命令

sudo apt install libnss-systemd libpam-systemd libsystemd0 libudev1 systemd systemd-sysv systemd-timesyncd udev